aboutsummaryrefslogtreecommitdiff
path: root/nix-rust/Cargo.toml
diff options
context:
space:
mode:
authorEelco Dolstra <edolstra@gmail.com>2019-09-12 18:22:48 +0200
committerEelco Dolstra <edolstra@gmail.com>2019-12-10 13:37:23 +0100
commitd832a355ea40930a6d61e454a162ef286b81891f (patch)
treee1347a9d8d9dd54114ffb6ab5cdd14993d0f8153 /nix-rust/Cargo.toml
parentdd5d76e2ed2907eec5dce1c0eaea9df31caef27c (diff)
Use rustls
In particular, this enables HTTP/2 support in reqwest, which is a lot more efficient.
Diffstat (limited to 'nix-rust/Cargo.toml')
-rw-r--r--nix-rust/Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/nix-rust/Cargo.toml b/nix-rust/Cargo.toml
index 8d882f98a..107fd976f 100644
--- a/nix-rust/Cargo.toml
+++ b/nix-rust/Cargo.toml
@@ -13,6 +13,6 @@ tar = "0.4"
libc = "0.2"
futures-preview = { version = "=0.3.0-alpha.18", features = ["compat"] }
#hyper = "0.12"
-reqwest = "0.9"
+reqwest = { version = "0.9", default-features = false, features = ["rustls-tls"] }
http = "0.1"
tokio = "0.1" \ No newline at end of file