aboutsummaryrefslogtreecommitdiff
path: root/package.nix
diff options
context:
space:
mode:
authorJade Lovelace <lix@jade.fyi>2024-05-30 13:44:01 -0700
committerjade <lix@jade.fyi>2024-05-30 21:54:21 +0000
commit0f99ed43f15aba7805ebe6d757a2d98418596205 (patch)
treef90b6b293ffc4036a24ec530566bbb0d383eeb50 /package.nix
parente6e5cacabeab0959d092aaf4957932a0b6f4b78e (diff)
build-time: remove 20% more by PCH'ing C++ stdlib
It seems like someone implemented precompiled headers a long time ago and then it never got ported to meson or maybe didn't work at all. This is, however, blessedly easy to simply implement. I went looking for `#define` that could affect the result of precompiling the headers, and as far as I can tell we aren't doing any of that, so this should truly just be free build time savings. Previous state: Compilation (551 times): Parsing (frontend): 1302.1 s Codegen & opts (backend): 956.3 s New state: **** Time summary: Compilation (567 times): Parsing (frontend): 1123.0 s Codegen & opts (backend): 1078.1 s I wonder if the "regression" in codegen time is just doing the PCH operation a few times, because meson does it per-target. Change-Id: I664366b8069bab4851308b3a7571bea97ac64022
Diffstat (limited to 'package.nix')
-rw-r--r--package.nix1
1 files changed, 0 insertions, 1 deletions
diff --git a/package.nix b/package.nix
index 283a590c1..43b709023 100644
--- a/package.nix
+++ b/package.nix
@@ -169,7 +169,6 @@ stdenv.mkDerivation (finalAttrs: {
./boehmgc-coroutine-sp-fallback.diff
./doc
./misc
- ./precompiled-headers.h
./src
./COPYING
]