aboutsummaryrefslogtreecommitdiff
path: root/package.nix
diff options
context:
space:
mode:
authorJade Lovelace <lix@jade.fyi>2024-06-24 15:57:38 -0700
committerJade Lovelace <lix@jade.fyi>2024-06-24 15:57:38 -0700
commit1245340e440c3b2c1f79269d02d5991dfb853122 (patch)
tree23dd71f9cb87501ec92dbf91453493457859a8f7 /package.nix
parentd5637ee790799ffa00bcaa3067bb6940b6cbad16 (diff)
packaging: don't build internal api docs by default in dev shells
These are totally available and you can just turn them on, but they have very bad dependency tracking and thus bloat incremental change times, which is not really ok. Change-Id: Iaa63ed18a789e74fcb757248cd24c3b194afcc80
Diffstat (limited to 'package.nix')
-rw-r--r--package.nix5
1 files changed, 5 insertions, 0 deletions
diff --git a/package.nix b/package.nix
index 988379618..0ade925ce 100644
--- a/package.nix
+++ b/package.nix
@@ -392,6 +392,7 @@ stdenv.mkDerivation (finalAttrs: {
bashInteractive,
clang-tools,
clangbuildanalyzer,
+ doxygen,
glibcLocales,
just,
llvmPackages,
@@ -457,6 +458,10 @@ stdenv.mkDerivation (finalAttrs: {
skopeo
just
nixfmt
+ # Included above when internalApiDocs is true, but we set that to
+ # false intentionally to save dev build time.
+ # To build them in a dev shell, you can set -Dinternal-api-docs=enabled when configuring.
+ doxygen
# Load-bearing order. Must come before clang-unwrapped below, but after clang_tools above.
stdenv.cc
]