aboutsummaryrefslogtreecommitdiff
path: root/package.nix
diff options
context:
space:
mode:
authorPierre Bourdon <delroth@gmail.com>2024-06-08 16:57:08 +0200
committerJade Lovelace <lix@jade.fyi>2024-06-12 15:34:23 -0700
commit248ecb11af9a5ebc6259f082c630197efd1730f3 (patch)
treece5e0526e5f4de87a3d89e2d60fa950f53cf1057 /package.nix
parent73898cad0e1dd99f63b24a6bf7cd21b9501c6d81 (diff)
dev shell: Add bashInteractive
This was bothersome to me as a zsh+direnv user. Change-Id: Ia5b54cc63647a5c6ced2b5412e972dac1abf8184
Diffstat (limited to 'package.nix')
-rw-r--r--package.nix20
1 files changed, 14 insertions, 6 deletions
diff --git a/package.nix b/package.nix
index 02bb1d3cd..f65611ea6 100644
--- a/package.nix
+++ b/package.nix
@@ -390,16 +390,20 @@ stdenv.mkDerivation (finalAttrs: {
mkDevShell =
{
mkShell,
- just,
- nixfmt,
- glibcLocales,
- pre-commit-checks,
+
+ bashInteractive,
clang-tools,
- llvmPackages,
clangbuildanalyzer,
- contribNotice,
+ glibcLocales,
+ just,
+ llvmPackages,
+ nixfmt,
skopeo,
xonsh,
+
+ # Lix specific packages
+ pre-commit-checks,
+ contribNotice,
}:
let
glibcFix = lib.optionalAttrs (buildPlatform.isLinux && glibcLocales != null) {
@@ -446,6 +450,10 @@ stdenv.mkDerivation (finalAttrs: {
packages =
lib.optional (stdenv.cc.isClang && hostPlatform == buildPlatform) clang-tools
++ [
+ # Why are we providing a bashInteractive? Well, when you run
+ # `bash` from inside `nix develop`, say, because you are using it
+ # via direnv, you will by default get bash (unusable edition).
+ bashInteractive
pythonEnv
# docker image tool
skopeo