aboutsummaryrefslogtreecommitdiff
path: root/package.nix
diff options
context:
space:
mode:
authoreldritch horrors <pennae@lix.systems>2024-03-26 18:32:25 +0100
committereldritch horrors <pennae@lix.systems>2024-03-27 03:09:14 +0000
commit279e30e7ef4cae96d1f5fcbc5fc02ebb4779199b (patch)
tree045935b89a5067c297cb50e7a28ca3a81cf411fc /package.nix
parent8fd02df90d2a8099d2d547e151b876f77fb5a4a2 (diff)
build: replace changelog-d with local script
hacking changelog-d to support not just github but also forgejo and gerrit is a lot more complicated than it's worth, even moreso since the entire thing can just as well be done with ~60 lines of python. this new script is also much cheaper to instantiate (being python), so having it enabled in all shells is far less of a hassle. we've also adjusted existing release notes that referenced a gerrit cl to auto-link to the cl in question, making the diff a bit bigger closes https://git.lix.systems/lix-project/lix/issues/176 Change-Id: I8ba7dd0070aad9ba4474401731215fcf5d9d2130
Diffstat (limited to 'package.nix')
-rw-r--r--package.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/package.nix b/package.nix
index 1392bbe62..3c4971605 100644
--- a/package.nix
+++ b/package.nix
@@ -8,7 +8,7 @@
boehmgc,
nlohmann_json,
bison,
- changelog-d,
+ build-release-notes,
boost,
brotli,
bzip2,
@@ -159,7 +159,7 @@ in stdenv.mkDerivation (finalAttrs: {
jq
lsof
] ++ lib.optional stdenv.hostPlatform.isLinux util-linuxMinimal
- ++ lib.optional (!officialRelease && buildUnreleasedNotes) changelog-d
+ ++ lib.optional (!officialRelease && buildUnreleasedNotes) build-release-notes
++ lib.optional internalApiDocs doxygen
++ lib.optionals buildWithMeson [
meson