aboutsummaryrefslogtreecommitdiff
path: root/package.nix
diff options
context:
space:
mode:
authorJade Lovelace <lix@jade.fyi>2024-08-09 22:26:51 -0700
committerJade Lovelace <lix@jade.fyi>2024-08-09 23:22:11 -0700
commit3775b6ac88720ab10237bab4817313c920daffcb (patch)
tree9063b98f95469d8bbf3028ea8646444181d27476 /package.nix
parent9851be99b9741ae9441354336d7f1f0235d03c48 (diff)
package: remove unused autotools code, empty file
I noticed there was some stuff setting configureFlags that definitely do not do anything with meson, so let's rip them out. As for the empty file, it was added when I was thinking I needed a fake C++ target to convince meson to create the necessary dependencies. That was not in fact possible so it should have never been committed. Change-Id: Ied4723d8a5d21aed85f352c48b080ab2c977a496
Diffstat (limited to 'package.nix')
-rw-r--r--package.nix7
1 files changed, 0 insertions, 7 deletions
diff --git a/package.nix b/package.nix
index ddceb23a5..18c8475bb 100644
--- a/package.nix
+++ b/package.nix
@@ -314,13 +314,6 @@ stdenv.mkDerivation (finalAttrs: {
install_name_tool -change ${boost}/lib/libboost_system.dylib $out/lib/libboost_system.dylib $out/lib/libboost_thread.dylib
''
+ ''
- # Workaround https://github.com/NixOS/nixpkgs/issues/294890.
- if [[ -n "''${doCheck:-}" ]]; then
- appendToVar configureFlags "--enable-tests"
- else
- appendToVar configureFlags "--disable-tests"
- fi
-
# Fix up /usr/bin/env shebangs relied on by the build
patchShebangs --build tests/ doc/manual/
'';