aboutsummaryrefslogtreecommitdiff
path: root/package.nix
diff options
context:
space:
mode:
authorJade Lovelace <lix@jade.fyi>2024-10-04 21:00:30 -0700
committerJade Lovelace <lix@jade.fyi>2024-10-09 14:47:39 -0700
commit3caf3e1e08220b59dee1dfe81549b3a0739f8565 (patch)
treeabf8eca882175ccc7b0347b49eaecd6105ba7ad0 /package.nix
parent9865ebaaa618d82a7b7fdccc636cbaa7dfa42427 (diff)
testsuite: add a functional2 test suite based on pytest
I am tired of bad shell scripts, let me write bad python quickly instead. It's definitely, $100%, better. This is not planned as an immediate replacement of the old test suite, but we::jade would not oppose tests getting ported. What is here is a mere starting point and there is a lot more functionality that we need. Fixes: https://git.lix.systems/lix-project/lix/issues/488 Change-Id: If762efce69030bb667491b263b874c36024bf7b6
Diffstat (limited to 'package.nix')
-rw-r--r--package.nix6
1 files changed, 6 insertions, 0 deletions
diff --git a/package.nix b/package.nix
index ff862bf92..b0b933ece 100644
--- a/package.nix
+++ b/package.nix
@@ -170,6 +170,7 @@ let
functionalTestFiles = fileset.unions [
./tests/functional
+ ./tests/functional2
./tests/unit
(fileset.fileFilter (f: lib.strings.hasPrefix "nix-profile" f.name) ./scripts)
];
@@ -243,6 +244,7 @@ stdenv.mkDerivation (finalAttrs: {
nativeBuildInputs =
[
python3
+ python3.pkgs.pytest
meson
ninja
cmake
@@ -474,6 +476,10 @@ stdenv.mkDerivation (finalAttrs: {
pythonPackages = (
p: [
+ # FIXME: these have to be added twice due to the nix shell using a
+ # wrapped python instead of build inputs for its python inputs
+ p.pytest
+
p.yapf
p.python-frontmatter
p.requests