aboutsummaryrefslogtreecommitdiff
path: root/package.nix
diff options
context:
space:
mode:
authorJade Lovelace <lix@jade.fyi>2024-06-09 17:10:44 -0700
committerJade Lovelace <lix@jade.fyi>2024-06-12 15:34:23 -0700
commit479055aee8a7e57669cbad608866014fab9fc05d (patch)
treef60492473953eaacb94e303925a777d70a25ef31 /package.nix
parentf7b655269965ed30d2fb15d2da5f5e1b0c0a61b5 (diff)
Misc workaround removals since 24.05 upgrade
Change-Id: I9491b103333cb0e25c245199e88365ded7800d2e
Diffstat (limited to 'package.nix')
-rw-r--r--package.nix6
1 files changed, 1 insertions, 5 deletions
diff --git a/package.nix b/package.nix
index d7b1374ed..02bb1d3cd 100644
--- a/package.nix
+++ b/package.nix
@@ -406,10 +406,6 @@ stdenv.mkDerivation (finalAttrs: {
# Required to make non-NixOS Linux not complain about missing locale files during configure in a dev shell
LOCALE_ARCHIVE = "${lib.getLib pkgs.glibcLocales}/lib/locale/locale-archive";
};
- # for some reason that seems accidental and was changed in
- # NixOS 24.05-pre, clang-tools is pinned to LLVM 14 when
- # default LLVM is newer.
- clang-tools_llvm = clang-tools.override { inherit llvmPackages; };
pythonPackages = (
p: [
@@ -448,7 +444,7 @@ stdenv.mkDerivation (finalAttrs: {
++ [ (lib.mesonBool "enable-pch-std" stdenv.cc.isClang) ];
packages =
- lib.optional (stdenv.cc.isClang && hostPlatform == buildPlatform) clang-tools_llvm
+ lib.optional (stdenv.cc.isClang && hostPlatform == buildPlatform) clang-tools
++ [
pythonEnv
# docker image tool