aboutsummaryrefslogtreecommitdiff
path: root/package.nix
diff options
context:
space:
mode:
authorJade Lovelace <lix@jade.fyi>2024-10-15 15:45:42 -0700
committerJade Lovelace <lix@jade.fyi>2024-10-18 15:40:22 -0700
commit77b6f6734f830058b2375cfc96b5e0fb482cc1c2 (patch)
treee9d701278360e392cc75b10233608b7aa9bfc896 /package.nix
parente2d00ac3a805bef7af8e7ec765af0d8ba34f4b3c (diff)
packaging: remove workaround for clang stdenv asserts
This workaround was for the stdenv not being set when callPackage'ing package.nix for some of the stranger CI outputs. Change-Id: I2acdd6efa721b90dd3cb04358544d25d591ff084
Diffstat (limited to 'package.nix')
-rw-r--r--package.nix6
1 files changed, 5 insertions, 1 deletions
diff --git a/package.nix b/package.nix
index e869fb74f..4bce7cb5e 100644
--- a/package.nix
+++ b/package.nix
@@ -112,7 +112,7 @@
}:
# gcc miscompiles coroutines at least until 13.2, possibly longer
-assert stdenv.cc.isClang || lintInsteadOfBuild || internalApiDocs;
+assert stdenv.cc.isClang;
let
inherit (__forDefaults) canRunInstalled;
@@ -274,6 +274,10 @@ stdenv.mkDerivation (finalAttrs: {
++ lib.optionals lintInsteadOfBuild [
# required for a wrapped clang-tidy
llvmPackages.clang-tools
+ # load-bearing order (just as below); the actual stdenv wrapped clang
+ # needs to precede the unwrapped clang in PATH such that calling `clang`
+ # can compile things.
+ stdenv.cc
# required for run-clang-tidy
llvmPackages.clang-unwrapped
];