aboutsummaryrefslogtreecommitdiff
path: root/package.nix
diff options
context:
space:
mode:
authorJade Lovelace <lix@jade.fyi>2024-08-07 20:14:45 -0700
committerJade Lovelace <lix@jade.fyi>2024-08-07 20:14:45 -0700
commit8a86f38bca61ab67dcc137c4966f32b3dc2251d9 (patch)
tree4a173037f5bb6915968f2535ed080ba5e0cd18b2 /package.nix
parent6fdb47f0b259a9ffbe4bdb349d6aaf03a0144092 (diff)
Fix is_maintenance_branch heuristic
This was broken because Nix language's version comparison does not know how to deal with versions like -rc1 and considers them newer, which is in this case not desirable. That in turn led to not tagging 2.90.0 docker images as "latest" since the heuristic was wrong. This commit also adds some more cross-checking and failsafes in case the person running releng does not have a local main branch that is up to date. Fixes: https://git.lix.systems/lix-project/lix/issues/443 Change-Id: I537103ebab58ae978c00e06972abe14432dd9c80
Diffstat (limited to 'package.nix')
-rw-r--r--package.nix1
1 files changed, 1 insertions, 0 deletions
diff --git a/package.nix b/package.nix
index be2f0010d..c32539303 100644
--- a/package.nix
+++ b/package.nix
@@ -423,6 +423,7 @@ stdenv.mkDerivation (finalAttrs: {
p.python-frontmatter
p.requests
p.xdg-base-dirs
+ p.packaging
(p.toPythonModule xonsh.passthru.unwrapped)
]
);