aboutsummaryrefslogtreecommitdiff
path: root/package.nix
diff options
context:
space:
mode:
authorJade Lovelace <lix@jade.fyi>2024-07-23 21:53:43 +0200
committerJade Lovelace <lix@jade.fyi>2024-07-23 21:53:43 +0200
commit98e8cf9c63e35d439326797c39bad12b2d24c9ae (patch)
tree49986aadfb43f90d4cfac90f4ffea638869477aa /package.nix
parent12a5838d11f790d36e2ac626e8916a2c19bcb80b (diff)
package.nix: remove dead code
Change-Id: Ic0dfcfe27dbf13da4f7f74f5fab8ce6fa718d28f
Diffstat (limited to 'package.nix')
-rw-r--r--package.nix38
1 files changed, 13 insertions, 25 deletions
diff --git a/package.nix b/package.nix
index 16477a6a2..bde48ae4b 100644
--- a/package.nix
+++ b/package.nix
@@ -92,31 +92,19 @@ let
# Reimplementation of Nixpkgs' Meson cross file, with some additions to make
# it actually work.
- mesonCrossFile =
- let
- cpuFamily =
- platform:
- with platform;
- if isAarch32 then
- "arm"
- else if isx86_32 then
- "x86"
- else
- platform.uname.processor;
- in
- builtins.toFile "lix-cross-file.conf" ''
- [properties]
- # Meson is convinced that if !buildPlatform.canExecute hostPlatform then we cannot
- # build anything at all, which is not at all correct. If we can't execute the host
- # platform, we'll just disable tests and doc gen.
- needs_exe_wrapper = false
-
- [binaries]
- # Meson refuses to consider any CMake binary during cross compilation if it's
- # not explicitly specified here, in the cross file.
- # https://github.com/mesonbuild/meson/blob/0ed78cf6fa6d87c0738f67ae43525e661b50a8a2/mesonbuild/cmake/executor.py#L72
- cmake = 'cmake'
- '';
+ mesonCrossFile = builtins.toFile "lix-cross-file.conf" ''
+ [properties]
+ # Meson is convinced that if !buildPlatform.canExecute hostPlatform then we cannot
+ # build anything at all, which is not at all correct. If we can't execute the host
+ # platform, we'll just disable tests and doc gen.
+ needs_exe_wrapper = false
+
+ [binaries]
+ # Meson refuses to consider any CMake binary during cross compilation if it's
+ # not explicitly specified here, in the cross file.
+ # https://github.com/mesonbuild/meson/blob/0ed78cf6fa6d87c0738f67ae43525e661b50a8a2/mesonbuild/cmake/executor.py#L72
+ cmake = 'cmake'
+ '';
# The internal API docs need these for the build, but if we're not building
# Nix itself, then these don't need to be propagated.