aboutsummaryrefslogtreecommitdiff
path: root/package.nix
diff options
context:
space:
mode:
authorIsabel <isabel@isabelroses.com>2024-08-02 07:56:06 +0000
committerGerrit Code Review <gerrit@localhost>2024-08-02 07:56:06 +0000
commit9eb374dc6da5cd0e8f96522342a5b0a27fc5946b (patch)
tree69b559e54e4433b501a4ae2ef60944dd90cc40f2 /package.nix
parent3bb8c627aecc4abd89e7863cc11a7aef1ee74ed7 (diff)
parentd2422771eb8e4186841ebab8ef486328e9a07d28 (diff)
Merge "nix flake show: add the description if it exists" into main
Diffstat (limited to 'package.nix')
-rw-r--r--package.nix3
1 files changed, 3 insertions, 0 deletions
diff --git a/package.nix b/package.nix
index 1b711585d..62927e569 100644
--- a/package.nix
+++ b/package.nix
@@ -20,6 +20,7 @@
doxygen,
editline-lix ? __forDefaults.editline-lix,
editline,
+ expect,
git,
gtest,
jq,
@@ -254,6 +255,8 @@ stdenv.mkDerivation (finalAttrs: {
++ lib.optional (hostPlatform.canExecute buildPlatform) aws-sdk-cpp-nix
++ lib.optionals (finalAttrs.dontBuild) maybePropagatedInputs;
+ nativeCheckInputs = [ expect ];
+
checkInputs = [
gtest
rapidcheck