aboutsummaryrefslogtreecommitdiff
path: root/package.nix
diff options
context:
space:
mode:
authorvigress8 <150687949+vigress8@users.noreply.github.com>2024-06-24 23:28:36 +0400
committerJade Lovelace <lix@jade.fyi>2024-06-24 14:00:43 -0700
commitc7af89c79771a6d4eb84baa6cd9b7551b3a84a4b (patch)
treee73517bef7dbbe45e14564d955ee7d25e88c9f3c /package.nix
parentd86009bd76ae85e56e1d26aab26d38f90ecb6439 (diff)
change shebangs of all .sh scripts to bash
On operating systems where /bin/sh is not Bash, some scripts are invalid because of bashisms, and building Lix fails with errors like this: `render-manpage.sh: 3: set: Illegal option -o pipefail` This modifies all scripts that use a `/bin/sh` shebang to `/usr/bin/env bash`, including currently POSIX-compliant ones, to prevent any future confusion. Change-Id: Ia074cc6db42d40fc59a63726f6194ea0149ea5e0
Diffstat (limited to 'package.nix')
-rw-r--r--package.nix3
1 files changed, 3 insertions, 0 deletions
diff --git a/package.nix b/package.nix
index ef6f317e8..4cd3c190a 100644
--- a/package.nix
+++ b/package.nix
@@ -304,6 +304,9 @@ stdenv.mkDerivation (finalAttrs: {
else
appendToVar configureFlags "--disable-tests"
fi
+
+ # Fix up /usr/bin/env shebangs relied on by the build
+ patchShebangs --build tests/ doc/manual/
'';
mesonBuildType = "debugoptimized";