aboutsummaryrefslogtreecommitdiff
path: root/package.nix
diff options
context:
space:
mode:
authoralois31 <alois1@gmx-topmail.de>2024-07-26 07:08:35 +0000
committerGerrit Code Review <gerrit@localhost>2024-07-26 07:08:35 +0000
commitd945e89e19bb508133bc563fb960b1cf1e785410 (patch)
tree6a29d77bb1f08e437651163ef58c0063ee0ac2a1 /package.nix
parent60a48311e84c228e664a44c8d049ea3080879a40 (diff)
parente7188e211a5a2ac0ba34635a846569560bb5f000 (diff)
Merge changes I45d3895f,I541be3ea,Ibe51416d into main
* changes: libstore/build: block io_uring libstore/build: use an allowlist approach to syscall filtering libstore/build: always treat seccomp setup failures as fatal
Diffstat (limited to 'package.nix')
-rw-r--r--package.nix2
1 files changed, 2 insertions, 0 deletions
diff --git a/package.nix b/package.nix
index bde48ae4b..e5e0033df 100644
--- a/package.nix
+++ b/package.nix
@@ -391,6 +391,7 @@ stdenv.mkDerivation (finalAttrs: {
# Lix specific packages
pre-commit-checks,
contribNotice,
+ check-syscalls,
}:
let
glibcFix = lib.optionalAttrs (buildPlatform.isLinux && glibcLocales != null) {
@@ -441,6 +442,7 @@ stdenv.mkDerivation (finalAttrs: {
# `bash` from inside `nix develop`, say, because you are using it
# via direnv, you will by default get bash (unusable edition).
bashInteractive
+ check-syscalls
pythonEnv
# docker image tool
skopeo