aboutsummaryrefslogtreecommitdiff
path: root/package.nix
diff options
context:
space:
mode:
authorRebecca Turner <rbt@sent.as>2024-09-11 09:34:42 -0700
committerRebecca Turner <rbt@sent.as>2024-09-11 09:35:00 -0700
commitdf0137226d7db4bfac455076be9f37dae6f01ffe (patch)
tree71cb6bf625a6d91449011bad404945477c23ba3a /package.nix
parent24db81eaf28259ab8f8334ccd6368673a26ed422 (diff)
editline: Vendor cl/1883 patch to recognize `Alt+Left`/`Alt+Right`
This vendors the patch added in cl/1883 to avoid GitHub garbage-collecting the commits we're referring to. As @emilazy pointed out on GitHub: > GitHub can garbage‐collect unmerged PR commits if they are later > force‐pushed, which means that code review in upstreams can cause > Nixpkgs builds to fail to reproduce in future. See: https://github.com/NixOS/nixpkgs/pull/341131#discussion_r1753046220 See: https://github.com/troglobit/editline/pull/70 See: https://gerrit.lix.systems/c/lix/+/1883 Change-Id: Ifff522f7f23310d6dbe9efc72fd40be5500ae872
Diffstat (limited to 'package.nix')
-rw-r--r--package.nix12
1 files changed, 2 insertions, 10 deletions
diff --git a/package.nix b/package.nix
index c9341d4cb..23ebc3a82 100644
--- a/package.nix
+++ b/package.nix
@@ -87,16 +87,8 @@
# Recognize `Alt-Left` and `Alt-Right` for navigating by words in more
# terminals/shells/platforms.
#
- # See: https://github.com/troglobit/editline/pull/70/commits
- (fetchpatch {
- url = "https://github.com/troglobit/editline/pull/70/commits/d0f2a5bc2300b96b2434c7838184c1dfd6a639f5.diff";
- hash = "sha256-0bbtYDUlk1wA0kpTtlaNI6KaCjLmAesZjcWBJZ+DpyQ=";
- })
-
- (fetchpatch {
- url = "https://github.com/troglobit/editline/pull/70/commits/4c4455353a0a88bee09d5f27c28f81f747682fed.diff";
- hash = "sha256-nVezspwVzeB/8zENeKgwPVum0W1MLv4dOW0967WbX5w=";
- })
+ # See: https://github.com/troglobit/editline/pull/70
+ ./nix-support/editline.patch
];
configureFlags = (prev.configureFlags or [ ]) ++ [