aboutsummaryrefslogtreecommitdiff
path: root/package.nix
diff options
context:
space:
mode:
authorQyriad <qyriad@qyriad.me>2024-04-23 10:20:20 -0600
committerQyriad <qyriad@qyriad.me>2024-04-23 10:20:20 -0600
commitf24223931d7f1588d41d39ac0afed77db99f8f8e (patch)
treed04a0a7ce204b43ee36b5c9342a9c7ca1055d0de /package.nix
parentbe4a3168c9bba52c7bb35e107a1ed917be41aa86 (diff)
meson: remove unnecessary parts of cross file
Meson cross files layer, the last value of each key takes effect. https: //mesonbuild.com/Machine-files.html#loading-multiple-machine-files Change-Id: I22d886f71cd51f0ce520d3fc22aed4bcf074bb91
Diffstat (limited to 'package.nix')
-rw-r--r--package.nix9
1 files changed, 0 insertions, 9 deletions
diff --git a/package.nix b/package.nix
index 63372caa1..c9cc17c29 100644
--- a/package.nix
+++ b/package.nix
@@ -116,21 +116,12 @@ let
in
builtins.toFile "lix-cross-file.conf" ''
[properties]
- bindgen_clang_arguments = ['-target', '${stdenv.targetPlatform.config}']
# Meson is convinced that if !buildPlatform.canExecute hostPlatform then we cannot
# build anything at all, which is not at all correct. If we can't execute the host
# platform, we'll just disable tests and doc gen.
needs_exe_wrapper = false
- [host_machine]
- system = '${stdenv.targetPlatform.parsed.kernel.name}'
- cpu_family = '${cpuFamily stdenv.targetPlatform}'
- cpu = '${stdenv.targetPlatform.parsed.cpu.name}'
- endian = ${if stdenv.targetPlatform.isLittleEndian then "'little'" else "'big'"}
-
[binaries]
- llvm-config = 'llvm-config-native'
- rust = ['rustc', '--target', '${stdenv.targetPlatform.rust.rustcTargetSpec}']
# Meson refuses to consider any CMake binary during cross compilation if it's
# not explicitly specified here, in the cross file.
# https://github.com/mesonbuild/meson/blob/0ed78cf6fa6d87c0738f67ae43525e661b50a8a2/mesonbuild/cmake/executor.py#L72