aboutsummaryrefslogtreecommitdiff
path: root/package.nix
diff options
context:
space:
mode:
authorJade Lovelace <lix@jade.fyi>2024-06-06 22:28:49 -0700
committerJade Lovelace <lix@jade.fyi>2024-06-09 00:30:12 -0700
commitff95b980d4913e90bc334227f8f3f7b3daf18b36 (patch)
tree08799eda970630ea1cc59142698fa99068db8fc6 /package.nix
parent98e847514795f53f485b6dbd029ecb545ce38236 (diff)
Implement docker upload in the releng tools
This uses skopeo to not think about docker daemons. I, however, noticed that the docker image we had would have totally terrible cache hits, so I rewrote it. Fixes: https://git.lix.systems/lix-project/lix/issues/252 Change-Id: I3c5b6c1f3ba0b9dfcac212b2148f390e0cd542b7
Diffstat (limited to 'package.nix')
-rw-r--r--package.nix3
1 files changed, 3 insertions, 0 deletions
diff --git a/package.nix b/package.nix
index 9c108308d..1ac54dab6 100644
--- a/package.nix
+++ b/package.nix
@@ -39,6 +39,7 @@
pkg-config,
python3,
rapidcheck,
+ skopeo,
sqlite,
toml11,
util-linuxMinimal ? utillinuxMinimal,
@@ -447,6 +448,8 @@ stdenv.mkDerivation (finalAttrs: {
lib.optional (stdenv.cc.isClang && hostPlatform == buildPlatform) clang-tools_llvm
++ [
pythonEnv
+ # docker image tool
+ skopeo
just
nixfmt
# Load-bearing order. Must come before clang-unwrapped below, but after clang_tools above.