aboutsummaryrefslogtreecommitdiff
path: root/perl/default.nix
diff options
context:
space:
mode:
authorQyriad <qyriad@qyriad.me>2024-05-07 13:34:36 -0600
committerQyriad <qyriad@qyriad.me>2024-05-07 17:04:30 -0600
commitb9be46fb3115dffcd5cdaa62523bd025c7342e42 (patch)
treee95c1b36bf9797ce725481246980cf7c353f829d /perl/default.nix
parentd184981af019f786df8ddb1b39527df30c62b262 (diff)
remove the autoconf+Make buildsystem
We're not using it anymore. Any leftover bugs in the Meson buildsystem are now just bugs. Closes #249. Change-Id: I0465a0c37ae819f94d40e7829f5bff046aa63d73
Diffstat (limited to 'perl/default.nix')
-rw-r--r--perl/default.nix41
1 files changed, 10 insertions, 31 deletions
diff --git a/perl/default.nix b/perl/default.nix
index af700eabe..7ce418402 100644
--- a/perl/default.nix
+++ b/perl/default.nix
@@ -4,8 +4,6 @@
stdenv,
perl,
perlPackages,
- autoconf-archive,
- autoreconfHook,
pkg-config,
nix,
curl,
@@ -16,7 +14,6 @@
darwin,
meson,
ninja,
- buildWithMeson ? false,
}:
perl.pkgs.toPerlModule (
@@ -25,36 +22,18 @@ perl.pkgs.toPerlModule (
src = fileset.toSource {
root = ../.;
- fileset = fileset.unions (
- [
- ../.version
- ./lib
- ]
- ++ lib.optionals (!buildWithMeson) [
- # FIXME(Qyriad): What the hell is this?
- # What is it used for and do we still need it?
- ./MANIFEST
- ../m4
- ../mk
- ./Makefile
- ./Makefile.config.in
- ./configure.ac
- ./local.mk
- ]
- ++ lib.optionals buildWithMeson [ ./meson.build ]
- );
+ fileset = fileset.unions ([
+ ../.version
+ ./lib
+ ./meson.build
+ ]);
};
- nativeBuildInputs =
- [ pkg-config ]
- ++ lib.optionals (!buildWithMeson) [
- autoconf-archive
- autoreconfHook
- ]
- ++ lib.optionals buildWithMeson [
- meson
- ninja
- ];
+ nativeBuildInputs = [
+ pkg-config
+ meson
+ ninja
+ ];
buildInputs =
[