aboutsummaryrefslogtreecommitdiff
path: root/release.nix
diff options
context:
space:
mode:
authorEelco Dolstra <edolstra@gmail.com>2018-08-30 16:03:06 +0200
committerEelco Dolstra <edolstra@gmail.com>2018-08-30 16:03:06 +0200
commit145db703e58fa8438413cb67a1361020850ce10e (patch)
tree4c69b66698131dcb5169691e729cd37bbf69c6b7 /release.nix
parent64d7d1a884838f6a15fd18d90f73a8061832af57 (diff)
Remove boost from the closure
This reduces the size of the closure by 45 MiB.
Diffstat (limited to 'release.nix')
-rw-r--r--release.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/release.nix b/release.nix
index beb8b5aa9..f9ee07e34 100644
--- a/release.nix
+++ b/release.nix
@@ -67,6 +67,14 @@ let
buildInputs = buildDeps;
+ preConfigure =
+ # Copy libboost_context so we don't get all of Boost in our closure.
+ # https://github.com/NixOS/nixpkgs/issues/45462
+ ''
+ mkdir -p $out/lib
+ cp ${boost}/lib/libboost_context* $out/lib
+ '';
+
configureFlags = configureFlags ++
[ "--sysconfdir=/etc" ];