aboutsummaryrefslogtreecommitdiff
path: root/release.nix
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2016-01-19 21:10:32 +0100
committerEelco Dolstra <eelco.dolstra@logicblox.com>2016-01-19 21:10:32 +0100
commit9fff4925613d44ac12775ad8840709130b9498d1 (patch)
treeda6578e8885e1c12a7d4d94634bfa4fb31b0c171 /release.nix
parentef53735f281cf0f5c54ac13ff649c696539d691d (diff)
Add tests for Nixpkgs/NixOS evaluation
Diffstat (limited to 'release.nix')
-rw-r--r--release.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/release.nix b/release.nix
index 293afcc24..406b089ca 100644
--- a/release.nix
+++ b/release.nix
@@ -234,6 +234,28 @@ let
touch $out/nix-support/hydra-build-products
''); # */
+ tests.evalNixpkgs =
+ { nixpkgs ? { outPath = pkgs.lib.cleanSource <nixpkgs>; revCount = 1234; shortRev = "abcdef"; } }:
+ import <nixpkgs/pkgs/top-level/make-tarball.nix> {
+ inherit nixpkgs;
+ inherit pkgs;
+ nix = build.x86_64-linux;
+ officialRelease = false;
+ };
+
+ tests.evalNixOS =
+ { nixpkgs ? { outPath = pkgs.lib.cleanSource <nixpkgs>; revCount = 1234; shortRev = "abcdef"; } }:
+ pkgs.runCommand "eval-nixos" { buildInputs = [ build.x86_64-linux ]; }
+ ''
+ export NIX_DB_DIR=$TMPDIR
+ export NIX_STATE_DIR=$TMPDIR
+ nix-store --init
+
+ nix-instantiate ${nixpkgs}/nixos/release-combined.nix -A tested --dry-run
+
+ touch $out
+ '';
+
# Aggregate job containing the release-critical jobs.
release = pkgs.releaseTools.aggregate {
@@ -264,6 +286,8 @@ let
tests.remoteBuilds
tests.nix-copy-closure
tests.binaryTarball
+ tests.evalNixpkgs
+ tests.evalNixOS
];
};