aboutsummaryrefslogtreecommitdiff
path: root/release.nix
diff options
context:
space:
mode:
authorEelco Dolstra <edolstra@gmail.com>2017-05-15 17:30:33 +0200
committerEelco Dolstra <edolstra@gmail.com>2017-05-15 17:36:32 +0200
commita2d92bb20e82a0957067ede60e91fab256948b41 (patch)
tree665a9274c830f73c05a282622d78f6cf8d7c9ec9 /release.nix
parentb30f5784d0184688de964f6239e373b62101ebc4 (diff)
Add --with-sandbox-shell configure flag
And add a 116 KiB ash shell from busybox to the release build. This helps to make sandbox builds work out of the box on non-NixOS systems and with diverted stores.
Diffstat (limited to 'release.nix')
-rw-r--r--release.nix9
1 files changed, 4 insertions, 5 deletions
diff --git a/release.nix b/release.nix
index 54d20c868..f1a553d01 100644
--- a/release.nix
+++ b/release.nix
@@ -66,6 +66,8 @@ let
with import <nixpkgs> { inherit system; };
+ with import ./release-common.nix { inherit pkgs; };
+
releaseTools.nixBuild {
name = "nix";
src = tarball;
@@ -83,11 +85,8 @@ let
customMemoryManagement = false;
});
- configureFlags = ''
- --disable-init-state
- --enable-gc
- --sysconfdir=/etc
- '';
+ configureFlags = configureFlags ++
+ [ "--sysconfdir=/etc" ];
enableParallelBuilding = true;