aboutsummaryrefslogtreecommitdiff
path: root/release.nix
diff options
context:
space:
mode:
authorEelco Dolstra <edolstra@gmail.com>2018-04-19 15:28:40 +0200
committerEelco Dolstra <edolstra@gmail.com>2018-04-19 15:29:31 +0200
commita99027d5870a772db550f741cb62aee612fcd5da (patch)
tree8be67e0aa131c21d1de89ea25758f13f27315a59 /release.nix
parent6f907b7571c792a8e33173fe41264b9cd0b750d9 (diff)
Fix tests.evalNixOS
This failed because NixOS' release.nix calls builtins.fetchGit.
Diffstat (limited to 'release.nix')
-rw-r--r--release.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/release.nix b/release.nix
index 9778b2db6..37deb8e7e 100644
--- a/release.nix
+++ b/release.nix
@@ -268,7 +268,8 @@ let
export NIX_STATE_DIR=$TMPDIR
nix-store --init
- nix-instantiate ${nixpkgs}/nixos/release-combined.nix -A tested --dry-run
+ nix-instantiate ${nixpkgs}/nixos/release-combined.nix -A tested --dry-run \
+ --arg nixpkgs '{ outPath = ${nixpkgs}; revCount = 123; shortRev = "abcdefgh"; }'
touch $out
'';