aboutsummaryrefslogtreecommitdiff
path: root/release.nix
diff options
context:
space:
mode:
authorEelco Dolstra <edolstra@gmail.com>2018-03-14 19:01:22 +0100
committerEelco Dolstra <edolstra@gmail.com>2018-03-14 19:24:04 +0100
commitca14b142001ab467e679d4ed0cc6236180bf34b2 (patch)
treeb7d89f1b6703eea64dc3aa9e6f2f354c3cd9f0c3 /release.nix
parent56f2ed00813f49e2834076787f98438a976eebb1 (diff)
Use boost::format from the boost package
Note that this only requires headers from boost so it doesn't add a runtime dependency. Also, use Nixpkgs 18.03.
Diffstat (limited to 'release.nix')
-rw-r--r--release.nix5
1 files changed, 3 insertions, 2 deletions
diff --git a/release.nix b/release.nix
index 0bbd966fa..2e9292955 100644
--- a/release.nix
+++ b/release.nix
@@ -1,5 +1,5 @@
{ nix ? builtins.fetchGit ./.
-, nixpkgs ? builtins.fetchGit https://github.com/NixOS/nixpkgs.git
+, nixpkgs ? builtins.fetchGit { url = https://github.com/NixOS/nixpkgs.git; ref = "release-18.03"; }
, officialRelease ? false
, systems ? [ "x86_64-linux" "i686-linux" "x86_64-darwin" "aarch64-linux" ]
}:
@@ -71,6 +71,7 @@ let
[ curl
bzip2 xz brotli
openssl pkgconfig sqlite boehmgc
+ boost
# Tests
git
@@ -192,7 +193,7 @@ let
doInstallCheck = true;
- lcovFilter = [ "*/boost/*" "*-tab.*" "*/nlohmann/*" "*/linenoise/*" ];
+ lcovFilter = [ "*-tab.*" "*/nlohmann/*" "*/linenoise/*" ];
# We call `dot', and even though we just use it to
# syntax-check generated dot files, it still requires some