aboutsummaryrefslogtreecommitdiff
path: root/release.nix
diff options
context:
space:
mode:
authorEelco Dolstra <edolstra@gmail.com>2018-02-20 12:33:32 +0100
committerEelco Dolstra <edolstra@gmail.com>2018-02-20 12:33:32 +0100
commitcea4fb3a31de8ae04faf8437c7b0ac6b964a1aad (patch)
tree28b67108cd4c5fa60018ecd61de2f86343f088ca /release.nix
parent056d28a60110975332d8cb0c08990a1d3d8060a7 (diff)
Fix evaluation of binaryTarball.aarch64-linux
Diffstat (limited to 'release.nix')
-rw-r--r--release.nix11
1 files changed, 6 insertions, 5 deletions
diff --git a/release.nix b/release.nix
index 9e04f0b67..3f8d5da47 100644
--- a/release.nix
+++ b/release.nix
@@ -1,5 +1,5 @@
{ nix ? builtins.fetchGit ./.
-, nixpkgs ? fetchTarball channel:nixos-17.09
+, nixpkgs ? builtins.fetchGit { url = https://github.com/NixOS/nixpkgs.git; ref = "nix-2.0"; }
, officialRelease ? false
, systems ? [ "x86_64-linux" "i686-linux" "x86_64-darwin" "aarch64-linux" ]
}:
@@ -127,7 +127,6 @@ let
binaryTarball = pkgs.lib.genAttrs systems (system:
- # FIXME: temporarily use a different branch for the Darwin build.
with import nixpkgs { inherit system; };
let
@@ -137,7 +136,7 @@ let
runCommand "nix-binary-tarball-${version}"
{ exportReferencesGraph = [ "closure1" toplevel "closure2" cacert ];
- buildInputs = [ perl shellcheck ];
+ buildInputs = [ perl ] ++ lib.optional (system != "aarch64-linux") shellcheck;
meta.description = "Distribution-independent Nix bootstrap binaries for ${system}";
}
''
@@ -150,8 +149,10 @@ let
--subst-var-by nix ${toplevel} \
--subst-var-by cacert ${cacert}
- shellcheck -e SC1090 $TMPDIR/install
- shellcheck -e SC1091,SC2002 $TMPDIR/install-darwin-multi-user
+ if type -p shellcheck; then
+ shellcheck -e SC1090 $TMPDIR/install
+ shellcheck -e SC1091,SC2002 $TMPDIR/install-darwin-multi-user
+ fi
chmod +x $TMPDIR/install
chmod +x $TMPDIR/install-darwin-multi-user