aboutsummaryrefslogtreecommitdiff
path: root/src/libexpr/fetchurl.nix
diff options
context:
space:
mode:
authorRebecca Turner <rbt@sent.as>2024-04-04 16:07:44 -0700
committerRebecca Turner <rbt@sent.as>2024-04-08 13:00:00 -0700
commitcfbcf122769d613e08ed906021d84ab5c0db95c0 (patch)
treef7ee0873b07cf94c8544b7862b332206da253ec5 /src/libexpr/fetchurl.nix
parentb3233405381b50c7f7eb87d7962b25a06d16be44 (diff)
Format Nix code with `nixfmt`
Change-Id: I61efeb666ff7481c05fcb247168290e86a250151
Diffstat (limited to 'src/libexpr/fetchurl.nix')
-rw-r--r--src/libexpr/fetchurl.nix102
1 files changed, 67 insertions, 35 deletions
diff --git a/src/libexpr/fetchurl.nix b/src/libexpr/fetchurl.nix
index 9d1b61d7f..50007c738 100644
--- a/src/libexpr/fetchurl.nix
+++ b/src/libexpr/fetchurl.nix
@@ -1,43 +1,75 @@
-{ system ? "" # obsolete
-, url
-, hash ? "" # an SRI hash
-
-# Legacy hash specification
-, md5 ? "", sha1 ? "", sha256 ? "", sha512 ? ""
-, outputHash ?
- if hash != "" then hash else if sha512 != "" then sha512 else if sha1 != "" then sha1 else if md5 != "" then md5 else sha256
-, outputHashAlgo ?
- if hash != "" then "" else if sha512 != "" then "sha512" else if sha1 != "" then "sha1" else if md5 != "" then "md5" else "sha256"
-
-, executable ? false
-, unpack ? false
-, name ? baseNameOf (toString url)
-, impure ? false
+{
+ system ? "", # obsolete
+ url,
+ hash ? "", # an SRI hash
+
+ # Legacy hash specification
+ md5 ? "",
+ sha1 ? "",
+ sha256 ? "",
+ sha512 ? "",
+ outputHash ?
+ if hash != "" then
+ hash
+ else if sha512 != "" then
+ sha512
+ else if sha1 != "" then
+ sha1
+ else if md5 != "" then
+ md5
+ else
+ sha256,
+ outputHashAlgo ?
+ if hash != "" then
+ ""
+ else if sha512 != "" then
+ "sha512"
+ else if sha1 != "" then
+ "sha1"
+ else if md5 != "" then
+ "md5"
+ else
+ "sha256",
+
+ executable ? false,
+ unpack ? false,
+ name ? baseNameOf (toString url),
+ impure ? false,
}:
-derivation ({
- builder = "builtin:fetchurl";
+derivation (
+ {
+ builder = "builtin:fetchurl";
- # New-style output content requirements.
- outputHashMode = if unpack || executable then "recursive" else "flat";
+ # New-style output content requirements.
+ outputHashMode = if unpack || executable then "recursive" else "flat";
- inherit name url executable unpack;
+ inherit
+ name
+ url
+ executable
+ unpack
+ ;
- system = "builtin";
+ system = "builtin";
- # No need to double the amount of network traffic
- preferLocalBuild = true;
+ # No need to double the amount of network traffic
+ preferLocalBuild = true;
- impureEnvVars = [
- # We borrow these environment variables from the caller to allow
- # easy proxy configuration. This is impure, but a fixed-output
- # derivation like fetchurl is allowed to do so since its result is
- # by definition pure.
- "http_proxy" "https_proxy" "ftp_proxy" "all_proxy" "no_proxy"
- ];
+ impureEnvVars = [
+ # We borrow these environment variables from the caller to allow
+ # easy proxy configuration. This is impure, but a fixed-output
+ # derivation like fetchurl is allowed to do so since its result is
+ # by definition pure.
+ "http_proxy"
+ "https_proxy"
+ "ftp_proxy"
+ "all_proxy"
+ "no_proxy"
+ ];
- # To make "nix-prefetch-url" work.
- urls = [ url ];
-} // (if impure
- then { __impure = true; }
- else { inherit outputHashAlgo outputHash; }))
+ # To make "nix-prefetch-url" work.
+ urls = [ url ];
+ }
+ // (if impure then { __impure = true; } else { inherit outputHashAlgo outputHash; })
+)