aboutsummaryrefslogtreecommitdiff
path: root/src/libstore/meson.build
diff options
context:
space:
mode:
authorQyriad <qyriad@qyriad.me>2024-04-18 16:15:24 -0600
committerQyriad <qyriad@qyriad.me>2024-04-18 16:15:58 -0600
commit111db8b38fd8350d92d72fa17fd3d9e8ef5a0e09 (patch)
tree93d0687870293ef4c59bc327c2bd2057c7ceebc5 /src/libstore/meson.build
parenta326344253ee55d50476ff696b83ffb15366852d (diff)
meson: correctly embed sandbox shell when asked
Change-Id: I2f6c0d42245204a516d2e424eea26a6391e975ad
Diffstat (limited to 'src/libstore/meson.build')
-rw-r--r--src/libstore/meson.build18
1 files changed, 18 insertions, 0 deletions
diff --git a/src/libstore/meson.build b/src/libstore/meson.build
index fbf818825..e1c6c267a 100644
--- a/src/libstore/meson.build
+++ b/src/libstore/meson.build
@@ -10,6 +10,24 @@ foreach header : [ 'schema.sql', 'ca-specific-schema.sql' ]
)
endforeach
+if enable_embedded_sandbox_shell
+ hexdump = find_program('hexdump', required : true)
+ embedded_sandbox_shell_gen = custom_target(
+ 'embedded-sandbox-shell.gen.hh',
+ command : [
+ hexdump,
+ '-v',
+ '-e',
+ '1/1 "0x%x," "\n"'
+ ],
+ input : busybox.full_path(),
+ output : 'embedded-sandbox-shell.gen.hh',
+ capture : true,
+ feed : true,
+ )
+ libstore_generated_headers += embedded_sandbox_shell_gen
+endif
+
libstore_sources = files(
'binary-cache-store.cc',
'build-result.cc',