aboutsummaryrefslogtreecommitdiff
path: root/src/libstore/meson.build
diff options
context:
space:
mode:
authorArtemis Tosini <me@artem.ist>2024-07-20 03:18:39 +0000
committerArtemis Tosini <me@artem.ist>2024-07-23 17:49:33 +0000
commit53f3e39815c3357c6465963359e94a6318b54af7 (patch)
tree3a251fe37ec302e404f50a0fd6bbe6daa0b90646 /src/libstore/meson.build
parent73c013a5df09a9edf7a6d2fa0be8349d89f856cd (diff)
libstore: Add FreeBSD findPlatformRoots
Use libprocstat to find garbage collector roots on FreeBSD. Tested working on a FreeBSD machine, although there is no CI yet Change-Id: Id36bac8c3de6cc4de94e2d76e9663dd4b76068a9
Diffstat (limited to 'src/libstore/meson.build')
-rw-r--r--src/libstore/meson.build35
1 files changed, 22 insertions, 13 deletions
diff --git a/src/libstore/meson.build b/src/libstore/meson.build
index fa363bd19..5416bd2b5 100644
--- a/src/libstore/meson.build
+++ b/src/libstore/meson.build
@@ -167,6 +167,9 @@ if host_machine.system() == 'linux'
elif host_machine.system() == 'darwin'
libstore_sources += files('platform/darwin.cc')
libstore_headers += files('platform/darwin.hh')
+elif host_machine.system() == 'freebsd'
+ libstore_sources += files('platform/freebsd.cc')
+ libstore_headers += files('platform/freebsd.hh')
else
libstore_sources += files('platform/fallback.cc')
libstore_headers += files('platform/fallback.hh')
@@ -202,23 +205,29 @@ foreach name, value : cpp_str_defines
]
endforeach
+dependencies = [
+ libarchive,
+ liblixutil, # Internal.
+ seccomp,
+ sqlite,
+ sodium,
+ curl,
+ openssl,
+ aws_sdk,
+ aws_s3,
+ aws_sdk_transfer,
+ nlohmann_json,
+]
+
+if host_machine.system() == 'freebsd'
+ dependencies += [ libprocstat ]
+endif
+
libstore = library(
'lixstore',
libstore_generated_headers,
libstore_sources,
- dependencies : [
- libarchive,
- liblixutil, # Internal.
- seccomp,
- sqlite,
- sodium,
- curl,
- openssl,
- aws_sdk,
- aws_s3,
- aws_sdk_transfer,
- nlohmann_json,
- ],
+ dependencies : dependencies,
cpp_args : cpp_args,
cpp_pch : cpp_pch,
install : true,