aboutsummaryrefslogtreecommitdiff
path: root/src/libutil/meson.build
diff options
context:
space:
mode:
authoreldritch horrors <pennae@lix.systems>2024-09-24 00:21:16 +0200
committereldritch horrors <pennae@lix.systems>2024-09-26 16:56:08 +0000
commit531d040e8c2d211408c84ae23421aaa45b3b5a7a (patch)
treebd702ae747efe8d0d62caf9f5d9a6e1e33a38033 /src/libutil/meson.build
parentca9256a789b413b71f424405c8a0d7d37ca36696 (diff)
libutil: add async collection mechanism
like kj::joinPromisesFailFast this allows waiting for the results of multiple promises at once, but unlike it not all input promises must be complete (or any of them failed) for results to become available. Change-Id: I0e4a37e7bd90651d56b33d0bc5afbadc56cde70c
Diffstat (limited to 'src/libutil/meson.build')
-rw-r--r--src/libutil/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/libutil/meson.build b/src/libutil/meson.build
index 89eeed133..afca4e021 100644
--- a/src/libutil/meson.build
+++ b/src/libutil/meson.build
@@ -53,6 +53,7 @@ libutil_headers = files(
'archive.hh',
'args/root.hh',
'args.hh',
+ 'async-collect.hh',
'async-semaphore.hh',
'backed-string-view.hh',
'box_ptr.hh',