aboutsummaryrefslogtreecommitdiff
path: root/src/nix-channel/meson.build
diff options
context:
space:
mode:
authorOlivia Crain <olivia@olivia.dev>2024-09-26 14:28:25 -0500
committerOlivia Crain <olivia@olivia.dev>2024-09-27 11:55:32 -0500
commit624f44bf25902beaf5599bf031ef3610820b1f6a (patch)
tree2273102c5ab68d877f1dd067059858354dfe7b42 /src/nix-channel/meson.build
parent0e6b3435a14a304b8833c27d2911de7ac4e731d4 (diff)
build: fix deprecated uses of configure_file
Using `configure_file` to copy files has been deprecated since Meson 0.64.0. The intended replacement is the `fs.copyfile` method. This removes the following deprecation warning that arises when a minimum Meson version is specified: `` Project [...] uses feature deprecated since '0.64.0': copy arg in configure_file. Use fs.copyfile instead `` Change-Id: I09ffc92e96311ef9ed594343a0a16d51e74b114a
Diffstat (limited to 'src/nix-channel/meson.build')
-rw-r--r--src/nix-channel/meson.build6
1 files changed, 1 insertions, 5 deletions
diff --git a/src/nix-channel/meson.build b/src/nix-channel/meson.build
index 952dfdb78..97b92d789 100644
--- a/src/nix-channel/meson.build
+++ b/src/nix-channel/meson.build
@@ -1,5 +1 @@
-configure_file(
- input : 'unpack-channel.nix',
- output : 'unpack-channel.nix',
- copy : true,
-)
+fs.copyfile('unpack-channel.nix')