aboutsummaryrefslogtreecommitdiff
path: root/src/nix/meson.build
diff options
context:
space:
mode:
authoreldritch horrors <pennae@lix.systems>2024-03-29 23:37:53 +0100
committereldritch horrors <pennae@lix.systems>2024-03-30 14:34:22 +0000
commit5956f509b6ab03d46fa86702449fccae2a1c42be (patch)
tree8b2a23391335b2e796ffcf85888211c64b1c1dc9 /src/nix/meson.build
parent351c1a9c528ea3f1a600515fdb27cabf2ea160bd (diff)
meson: install libexec binaries
Change-Id: I149892bf081e1569d7786f085e890bc3d2eb50e5
Diffstat (limited to 'src/nix/meson.build')
-rw-r--r--src/nix/meson.build8
1 files changed, 8 insertions, 0 deletions
diff --git a/src/nix/meson.build b/src/nix/meson.build
index 61fc36c9c..cb8f73174 100644
--- a/src/nix/meson.build
+++ b/src/nix/meson.build
@@ -118,3 +118,11 @@ foreach linkname : nix_symlinks
install_tag : 'runtime'
)
endforeach
+
+install_symlink(
+ 'build-remote',
+ pointing_to : bindir / 'nix',
+ install_dir : libexecdir / 'nix',
+ # The 'runtime' tag is what executables default to, which we want to emulate here.
+ install_tag : 'runtime'
+)