aboutsummaryrefslogtreecommitdiff
path: root/subprojects/lix-clang-tidy/meson.build
diff options
context:
space:
mode:
authorJade Lovelace <lix@jade.fyi>2024-08-04 22:02:53 -0700
committerJade Lovelace <lix@jade.fyi>2024-08-08 14:53:17 -0700
commita5f0954c290157875b4dfb79edcf651f55742dc2 (patch)
tree16efd430c4c0828ee236eda636015e79e15bb965 /subprojects/lix-clang-tidy/meson.build
parenta85c4ce535c940bd2f48c34ab823fb3a8f5be0cc (diff)
clang-tidy: write a lint for charptr_cast
This lets us ensure that nobody is putting in new reinterpret_cast instances where they could safely use charptr_cast instead. Change-Id: I6358a3934c8133c7150042635843bdbb6b9218d4
Diffstat (limited to 'subprojects/lix-clang-tidy/meson.build')
-rw-r--r--subprojects/lix-clang-tidy/meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/subprojects/lix-clang-tidy/meson.build b/subprojects/lix-clang-tidy/meson.build
index ef0226420..43648a1c8 100644
--- a/subprojects/lix-clang-tidy/meson.build
+++ b/subprojects/lix-clang-tidy/meson.build
@@ -5,9 +5,10 @@ project('lix-clang-tidy', ['cpp', 'c'],
llvm = dependency('Clang', version: '>= 17', modules: ['libclang'])
sources = files(
+ 'CharPtrCast.cc',
+ 'FixIncludes.cc',
'HasPrefixSuffix.cc',
'LixClangTidyChecks.cc',
- 'FixIncludes.cc',
)
lix_clang_tidy = shared_module('lix-clang-tidy', sources,