aboutsummaryrefslogtreecommitdiff
path: root/tests/build-hook.nix
diff options
context:
space:
mode:
authorJohn Ericson <John.Ericson@Obsidian.Systems>2020-08-12 16:32:36 +0000
committerJohn Ericson <John.Ericson@Obsidian.Systems>2020-08-12 18:13:00 +0000
commit4720853129b6866775edd9f90ad6f10701f98a3c (patch)
treea13e1d077c6254de55521bf9edd91749546c71b5 /tests/build-hook.nix
parent574bf60b4d47f64c0b83b0cd032d34a67dbb3453 (diff)
Make `system-features` a store setting
This seems more correct. It also means one can specify the features a store should support with --store and remote-store=..., which is useful. I use this to clean up the build remotes test.
Diffstat (limited to 'tests/build-hook.nix')
-rw-r--r--tests/build-hook.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/tests/build-hook.nix b/tests/build-hook.nix
index a19c10dde..1bd0b759f 100644
--- a/tests/build-hook.nix
+++ b/tests/build-hook.nix
@@ -23,6 +23,7 @@ let
shell = busybox;
name = "build-remote-input-2";
buildCommand = "echo BAR > $out";
+ requiredSystemFeatures = ["bar"];
};
in
@@ -34,6 +35,6 @@ in
''
read x < ${input1}
read y < ${input2}
- echo $x$y > $out
+ echo "$x $y" > $out
'';
}