aboutsummaryrefslogtreecommitdiff
path: root/tests/check-refs.nix
diff options
context:
space:
mode:
authorJohn Ericson <John.Ericson@Obsidian.Systems>2023-10-05 12:12:18 -0400
committerJohn Ericson <John.Ericson@Obsidian.Systems>2023-12-01 12:06:43 -0500
commit30dcc19d1f30fc203be460134c4578509cce704f (patch)
tree6cc32609b9984a2c4d5ecc0cac5cf30609e208b9 /tests/check-refs.nix
parent72425212657d795dc215b334b7c8c8cd36d06b72 (diff)
Put functional tests in `tests/functional`
I think it is bad for these reasons when `tests/` contains a mix of functional and integration tests - Concepts is harder to understand, the documentation makes a good unit vs functional vs integration distinction, but when the integration tests are just two subdirs within `tests/` this is not clear. - Source filtering in the `flake.nix` is more complex. We need to filter out some of the dirs from `tests/`, rather than simply pick the dirs we want and take all of them. This is a good sign the structure of what we are trying to do is not matching the structure of the files. With this change we have a clean: ```shell-session $ git show 'HEAD:tests' tree HEAD:tests functional/ installer/ nixos/ ``` (cherry picked from commit 68c81c737571794f7246db53fb4774e94fcf4b7e)
Diffstat (limited to 'tests/check-refs.nix')
-rw-r--r--tests/check-refs.nix77
1 files changed, 0 insertions, 77 deletions
diff --git a/tests/check-refs.nix b/tests/check-refs.nix
deleted file mode 100644
index 89690e456..000000000
--- a/tests/check-refs.nix
+++ /dev/null
@@ -1,77 +0,0 @@
-with import ./config.nix;
-
-rec {
-
- dep = import ./dependencies.nix {};
-
- makeTest = nr: args: mkDerivation ({
- name = "check-refs-" + toString nr;
- } // args);
-
- src = builtins.toFile "aux-ref" "bla bla";
-
- test1 = makeTest 1 {
- builder = builtins.toFile "builder.sh" "mkdir $out; ln -s $dep $out/link";
- inherit dep;
- };
-
- test2 = makeTest 2 {
- builder = builtins.toFile "builder.sh" "mkdir $out; ln -s ${src} $out/link";
- inherit dep;
- };
-
- test3 = makeTest 3 {
- builder = builtins.toFile "builder.sh" "mkdir $out; ln -s $dep $out/link";
- allowedReferences = [];
- inherit dep;
- };
-
- test4 = makeTest 4 {
- builder = builtins.toFile "builder.sh" "mkdir $out; ln -s $dep $out/link";
- allowedReferences = [dep];
- inherit dep;
- };
-
- test5 = makeTest 5 {
- builder = builtins.toFile "builder.sh" "mkdir $out";
- allowedReferences = [];
- inherit dep;
- };
-
- test6 = makeTest 6 {
- builder = builtins.toFile "builder.sh" "mkdir $out; ln -s $out $out/link";
- allowedReferences = [];
- inherit dep;
- };
-
- test7 = makeTest 7 {
- builder = builtins.toFile "builder.sh" "mkdir $out; ln -s $out $out/link";
- allowedReferences = ["out"];
- inherit dep;
- };
-
- test8 = makeTest 8 {
- builder = builtins.toFile "builder.sh" "mkdir $out; ln -s ${test1} $out/link";
- inherit dep;
- };
-
- test9 = makeTest 9 {
- builder = builtins.toFile "builder.sh" "mkdir $out; ln -s $dep $out/link";
- inherit dep;
- disallowedReferences = [dep];
- };
-
- test10 = makeTest 10 {
- builder = builtins.toFile "builder.sh" "mkdir $out; echo $test5; ln -s $dep $out/link";
- inherit dep test5;
- disallowedReferences = [test5];
- };
-
- test11 = makeTest 11 {
- __structuredAttrs = true;
- unsafeDiscardReferences.out = true;
- outputChecks.out.allowedReferences = [];
- buildCommand = ''echo ${dep} > "''${outputs[out]}"'';
- };
-
-}