aboutsummaryrefslogtreecommitdiff
path: root/tests/functional/dependencies.nix
diff options
context:
space:
mode:
authorJohn Ericson <John.Ericson@Obsidian.Systems>2023-10-05 12:12:18 -0400
committerJohn Ericson <John.Ericson@Obsidian.Systems>2023-12-01 12:06:43 -0500
commit30dcc19d1f30fc203be460134c4578509cce704f (patch)
tree6cc32609b9984a2c4d5ecc0cac5cf30609e208b9 /tests/functional/dependencies.nix
parent72425212657d795dc215b334b7c8c8cd36d06b72 (diff)
Put functional tests in `tests/functional`
I think it is bad for these reasons when `tests/` contains a mix of functional and integration tests - Concepts is harder to understand, the documentation makes a good unit vs functional vs integration distinction, but when the integration tests are just two subdirs within `tests/` this is not clear. - Source filtering in the `flake.nix` is more complex. We need to filter out some of the dirs from `tests/`, rather than simply pick the dirs we want and take all of them. This is a good sign the structure of what we are trying to do is not matching the structure of the files. With this change we have a clean: ```shell-session $ git show 'HEAD:tests' tree HEAD:tests functional/ installer/ nixos/ ``` (cherry picked from commit 68c81c737571794f7246db53fb4774e94fcf4b7e)
Diffstat (limited to 'tests/functional/dependencies.nix')
-rw-r--r--tests/functional/dependencies.nix48
1 files changed, 48 insertions, 0 deletions
diff --git a/tests/functional/dependencies.nix b/tests/functional/dependencies.nix
new file mode 100644
index 000000000..be1a7ae9a
--- /dev/null
+++ b/tests/functional/dependencies.nix
@@ -0,0 +1,48 @@
+{ hashInvalidator ? "" }:
+with import ./config.nix;
+
+let {
+
+ input0 = mkDerivation {
+ name = "dependencies-input-0";
+ buildCommand = "mkdir $out; echo foo > $out/bar";
+ };
+
+ input1 = mkDerivation {
+ name = "dependencies-input-1";
+ buildCommand = "mkdir $out; echo FOO > $out/foo";
+ };
+
+ input2 = mkDerivation {
+ name = "dependencies-input-2";
+ buildCommand = ''
+ mkdir $out
+ echo BAR > $out/bar
+ echo ${input0} > $out/input0
+ '';
+ };
+
+ fod_input = mkDerivation {
+ name = "fod-input";
+ buildCommand = ''
+ echo ${hashInvalidator}
+ echo FOD > $out
+ '';
+ outputHashMode = "flat";
+ outputHashAlgo = "sha256";
+ outputHash = "1dq9p0hnm1y75q2x40fws5887bq1r840hzdxak0a9djbwvx0b16d";
+ };
+
+ body = mkDerivation {
+ name = "dependencies-top";
+ builder = ./dependencies.builder0.sh + "/FOOBAR/../.";
+ input1 = input1 + "/.";
+ input2 = "${input2}/.";
+ input1_drv = input1;
+ input2_drv = input2;
+ input0_drv = input0;
+ fod_input_drv = fod_input;
+ meta.description = "Random test package";
+ };
+
+}