aboutsummaryrefslogtreecommitdiff
path: root/tests/functional/fixed.nix
diff options
context:
space:
mode:
authorJohn Ericson <John.Ericson@Obsidian.Systems>2023-10-05 12:12:18 -0400
committerJohn Ericson <John.Ericson@Obsidian.Systems>2023-12-01 12:06:43 -0500
commit30dcc19d1f30fc203be460134c4578509cce704f (patch)
tree6cc32609b9984a2c4d5ecc0cac5cf30609e208b9 /tests/functional/fixed.nix
parent72425212657d795dc215b334b7c8c8cd36d06b72 (diff)
Put functional tests in `tests/functional`
I think it is bad for these reasons when `tests/` contains a mix of functional and integration tests - Concepts is harder to understand, the documentation makes a good unit vs functional vs integration distinction, but when the integration tests are just two subdirs within `tests/` this is not clear. - Source filtering in the `flake.nix` is more complex. We need to filter out some of the dirs from `tests/`, rather than simply pick the dirs we want and take all of them. This is a good sign the structure of what we are trying to do is not matching the structure of the files. With this change we have a clean: ```shell-session $ git show 'HEAD:tests' tree HEAD:tests functional/ installer/ nixos/ ``` (cherry picked from commit 68c81c737571794f7246db53fb4774e94fcf4b7e)
Diffstat (limited to 'tests/functional/fixed.nix')
-rw-r--r--tests/functional/fixed.nix58
1 files changed, 58 insertions, 0 deletions
diff --git a/tests/functional/fixed.nix b/tests/functional/fixed.nix
new file mode 100644
index 000000000..babe71504
--- /dev/null
+++ b/tests/functional/fixed.nix
@@ -0,0 +1,58 @@
+with import ./config.nix;
+
+rec {
+
+ f2 = dummy: builder: mode: algo: hash: mkDerivation {
+ name = "fixed";
+ inherit builder;
+ outputHashMode = mode;
+ outputHashAlgo = algo;
+ outputHash = hash;
+ inherit dummy;
+ impureEnvVars = ["IMPURE_VAR1" "IMPURE_VAR2"];
+ };
+
+ f = f2 "";
+
+ good = [
+ (f ./fixed.builder1.sh "flat" "md5" "8ddd8be4b179a529afa5f2ffae4b9858")
+ (f ./fixed.builder1.sh "flat" "sha1" "a0b65939670bc2c010f4d5d6a0b3e4e4590fb92b")
+ (f ./fixed.builder2.sh "recursive" "md5" "3670af73070fa14077ad74e0f5ea4e42")
+ (f ./fixed.builder2.sh "recursive" "sha1" "vw46m23bizj4n8afrc0fj19wrp7mj3c0")
+ ];
+
+ # Expression to test that `nix-build --check` also throws an error if the hash of
+ # fixed-output derivation has changed even if the hash exists in the store (in this
+ # case the hash exists because of `fixed.builder2.sh`, but building a derivation
+ # with the same hash and a different result must throw an error).
+ check = [
+ (f ./fixed.builder1.sh "recursive" "md5" "3670af73070fa14077ad74e0f5ea4e42")
+ ];
+
+ good2 = [
+ # Yes, this looks fscked up: builder2 doesn't have that result.
+ # But Nix sees that an output with the desired hash already
+ # exists, and will refrain from building it.
+ (f ./fixed.builder2.sh "flat" "md5" "8ddd8be4b179a529afa5f2ffae4b9858")
+ ];
+
+ sameAsAdd =
+ f ./fixed.builder2.sh "recursive" "sha256" "1ixr6yd3297ciyp9im522dfxpqbkhcw0pylkb2aab915278fqaik";
+
+ bad = [
+ (f ./fixed.builder1.sh "flat" "md5" "0ddd8be4b179a529afa5f2ffae4b9858")
+ ];
+
+ reallyBad = [
+ # Hash too short, and not base-32 either.
+ (f ./fixed.builder1.sh "flat" "md5" "ddd8be4b179a529afa5f2ffae4b9858")
+ ];
+
+ # Test for building two derivations in parallel that produce the
+ # same output path because they're fixed-output derivations.
+ parallelSame = [
+ (f2 "foo" ./fixed.builder2.sh "recursive" "md5" "3670af73070fa14077ad74e0f5ea4e42")
+ (f2 "bar" ./fixed.builder2.sh "recursive" "md5" "3670af73070fa14077ad74e0f5ea4e42")
+ ];
+
+}