aboutsummaryrefslogtreecommitdiff
path: root/tests/functional/lang/eval-okay-builtins.nix
diff options
context:
space:
mode:
authorpiegames <git@piegames.de>2024-08-18 17:28:04 +0200
committerpiegames <git@piegames.de>2024-08-21 06:55:52 +0000
commit0a8888d1c7220eddba40895a9c6c63d06edf4614 (patch)
treea2400fb5880129a0a82225038c59611ed8da90ff /tests/functional/lang/eval-okay-builtins.nix
parent7210ed1b87410a0df597c0c4efe642bf82cc2b06 (diff)
treewide: Stop using ancient let syntax
Shows for how long these tests have not been touched by anyone … Change-Id: I3d0c1209a86283ddb012db4e7d45073264fdd0eb
Diffstat (limited to 'tests/functional/lang/eval-okay-builtins.nix')
-rw-r--r--tests/functional/lang/eval-okay-builtins.nix7
1 files changed, 3 insertions, 4 deletions
diff --git a/tests/functional/lang/eval-okay-builtins.nix b/tests/functional/lang/eval-okay-builtins.nix
index e9d65e88a..551eb3517 100644
--- a/tests/functional/lang/eval-okay-builtins.nix
+++ b/tests/functional/lang/eval-okay-builtins.nix
@@ -1,12 +1,11 @@
assert builtins ? currentSystem;
assert !builtins ? __currentSystem;
-let {
+let
x = if builtins ? dirOf then builtins.dirOf /foo/bar else "";
y = if builtins ? fnord then builtins.fnord "foo" else "";
- body = x + y;
-
-}
+in
+x + y