aboutsummaryrefslogtreecommitdiff
path: root/tests/functional/lang/eval-okay-eq-derivations.nix
diff options
context:
space:
mode:
authorJohn Ericson <John.Ericson@Obsidian.Systems>2023-12-01 13:53:13 -0500
committerGitHub <noreply@github.com>2023-12-01 13:53:13 -0500
commit211b6e18556e03829ae7bba38c7272af2900a2e8 (patch)
treebfcfef3efeb73cb0c3c6d812280191d03bda1233 /tests/functional/lang/eval-okay-eq-derivations.nix
parent72425212657d795dc215b334b7c8c8cd36d06b72 (diff)
parentf7f37035c81fa825a4dfc2df1ad2589013ac6380 (diff)
Merge pull request #9517 from NixOS/2.18-flatten-tests
[Backport 2.18-maintanence] Backport test source layout reorgs
Diffstat (limited to 'tests/functional/lang/eval-okay-eq-derivations.nix')
-rw-r--r--tests/functional/lang/eval-okay-eq-derivations.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/tests/functional/lang/eval-okay-eq-derivations.nix b/tests/functional/lang/eval-okay-eq-derivations.nix
new file mode 100644
index 000000000..d526cb4a2
--- /dev/null
+++ b/tests/functional/lang/eval-okay-eq-derivations.nix
@@ -0,0 +1,10 @@
+let
+
+ drvA1 = derivation { name = "a"; builder = "/foo"; system = "i686-linux"; };
+ drvA2 = derivation { name = "a"; builder = "/foo"; system = "i686-linux"; };
+ drvA3 = derivation { name = "a"; builder = "/foo"; system = "i686-linux"; } // { dummy = 1; };
+
+ drvC1 = derivation { name = "c"; builder = "/foo"; system = "i686-linux"; };
+ drvC2 = derivation { name = "c"; builder = "/bar"; system = "i686-linux"; };
+
+in [ (drvA1 == drvA1) (drvA1 == drvA2) (drvA1 == drvA3) (drvC1 == drvC2) ]