aboutsummaryrefslogtreecommitdiff
path: root/tests/functional/lang/parse-fail-dup-attrs-2.nix
diff options
context:
space:
mode:
authorShea Levy <shea@shealevy.com>2024-01-11 07:21:16 -0500
committerShea Levy <shea@shealevy.com>2024-01-11 07:21:16 -0500
commitba48ab4b954dd1c8af388d1c5a33bbd62373c6f5 (patch)
treef17f8492bed32f78c04d9d4e9ffd2b672af85943 /tests/functional/lang/parse-fail-dup-attrs-2.nix
parente7c2b35827e9f4ddbec4248c5cf1ad793a2988ad (diff)
parent4dd5171652018e29bf9e496522df3be51d615a2c (diff)
Merge branch '2.18-maintenance' into ifd-buildStore-2.18
Diffstat (limited to 'tests/functional/lang/parse-fail-dup-attrs-2.nix')
-rw-r--r--tests/functional/lang/parse-fail-dup-attrs-2.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/tests/functional/lang/parse-fail-dup-attrs-2.nix b/tests/functional/lang/parse-fail-dup-attrs-2.nix
new file mode 100644
index 000000000..864d9865e
--- /dev/null
+++ b/tests/functional/lang/parse-fail-dup-attrs-2.nix
@@ -0,0 +1,13 @@
+let {
+
+ as = {
+ x = 123;
+ y = 456;
+ };
+
+ bs = {
+ x = 789;
+ inherit (as) x;
+ };
+
+}