aboutsummaryrefslogtreecommitdiff
path: root/tests/functional/recursive.nix
diff options
context:
space:
mode:
authorJohn Ericson <John.Ericson@Obsidian.Systems>2023-10-05 12:12:18 -0400
committerJohn Ericson <John.Ericson@Obsidian.Systems>2023-12-01 12:06:43 -0500
commit30dcc19d1f30fc203be460134c4578509cce704f (patch)
tree6cc32609b9984a2c4d5ecc0cac5cf30609e208b9 /tests/functional/recursive.nix
parent72425212657d795dc215b334b7c8c8cd36d06b72 (diff)
Put functional tests in `tests/functional`
I think it is bad for these reasons when `tests/` contains a mix of functional and integration tests - Concepts is harder to understand, the documentation makes a good unit vs functional vs integration distinction, but when the integration tests are just two subdirs within `tests/` this is not clear. - Source filtering in the `flake.nix` is more complex. We need to filter out some of the dirs from `tests/`, rather than simply pick the dirs we want and take all of them. This is a good sign the structure of what we are trying to do is not matching the structure of the files. With this change we have a clean: ```shell-session $ git show 'HEAD:tests' tree HEAD:tests functional/ installer/ nixos/ ``` (cherry picked from commit 68c81c737571794f7246db53fb4774e94fcf4b7e)
Diffstat (limited to 'tests/functional/recursive.nix')
-rw-r--r--tests/functional/recursive.nix56
1 files changed, 56 insertions, 0 deletions
diff --git a/tests/functional/recursive.nix b/tests/functional/recursive.nix
new file mode 100644
index 000000000..fa8cc04db
--- /dev/null
+++ b/tests/functional/recursive.nix
@@ -0,0 +1,56 @@
+with import ./config.nix;
+
+mkDerivation rec {
+ name = "recursive";
+ dummy = builtins.toFile "dummy" "bla bla";
+ SHELL = shell;
+
+ # Note: this is a string without context.
+ unreachable = builtins.getEnv "unreachable";
+
+ NIX_TESTS_CA_BY_DEFAULT = builtins.getEnv "NIX_TESTS_CA_BY_DEFAULT";
+
+ requiredSystemFeatures = [ "recursive-nix" ];
+
+ buildCommand = ''
+ mkdir $out
+ opts="--experimental-features nix-command ${if (NIX_TESTS_CA_BY_DEFAULT == "1") then "--extra-experimental-features ca-derivations" else ""}"
+
+ PATH=${builtins.getEnv "NIX_BIN_DIR"}:$PATH
+
+ # Check that we can query/build paths in our input closure.
+ nix $opts path-info $dummy
+ nix $opts build $dummy
+
+ # Make sure we cannot query/build paths not in out input closure.
+ [[ -e $unreachable ]]
+ (! nix $opts path-info $unreachable)
+ (! nix $opts build $unreachable)
+
+ # Add something to the store.
+ echo foobar > foobar
+ foobar=$(nix $opts store add-path ./foobar)
+
+ nix $opts path-info $foobar
+ nix $opts build $foobar
+
+ # Add it to our closure.
+ ln -s $foobar $out/foobar
+
+ [[ $(nix $opts path-info --all | wc -l) -eq 4 ]]
+
+ # Build a derivation.
+ nix $opts build -L --impure --expr '
+ with import ${./config.nix};
+ mkDerivation {
+ name = "inner1";
+ buildCommand = "echo $fnord blaat > $out";
+ fnord = builtins.toFile "fnord" "fnord";
+ }
+ '
+
+ [[ $(nix $opts path-info --json ./result) =~ fnord ]]
+
+ ln -s $(nix $opts path-info ./result) $out/inner1
+ '';
+}