aboutsummaryrefslogtreecommitdiff
path: root/tests/functional/shell.shebang.nix
diff options
context:
space:
mode:
authorRebecca Turner <rbt@sent.as>2024-03-27 10:16:16 -0700
committerRebecca Turner <rbt@sent.as>2024-03-29 22:57:40 -0700
commit2a98ba8b97c9ff52519633c32cf63716827d6e7c (patch)
tree7b64c40ad064183cc7bc7afc662890ea567f2136 /tests/functional/shell.shebang.nix
parenta4f5bb951dbc6fa4ffa2bb56376b38f38b6e9154 (diff)
Add `pre-commit` checks
The big ones here are `trim-trailing-whitespace` and `end-of-file-fixer` (which makes sure that every file ends with exactly one newline character). Change-Id: Idca73b640883188f068f9903e013cf0d82aa1123
Diffstat (limited to 'tests/functional/shell.shebang.nix')
-rwxr-xr-xtests/functional/shell.shebang.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/functional/shell.shebang.nix b/tests/functional/shell.shebang.nix
index 08e43d53c..00124255b 100755
--- a/tests/functional/shell.shebang.nix
+++ b/tests/functional/shell.shebang.nix
@@ -1,6 +1,6 @@
#! @ENV_PROG@ nix-shell
#! nix-shell -I nixpkgs=shell.nix --no-substitute
-#! nix-shell --argstr s1 'foo "bar" \baz'"'"'qux' --argstr s2 "foo 'bar' \"\baz" --argstr s3 \foo\ bar\'baz --argstr s4 ''
+#! nix-shell --argstr s1 'foo "bar" \baz'"'"'qux' --argstr s2 "foo 'bar' \"\baz" --argstr s3 \foo\ bar\'baz --argstr s4 ''
#! nix-shell shell.shebang.nix --command true
{ s1, s2, s3, s4 }:
assert s1 == ''foo "bar" \baz'qux'';