aboutsummaryrefslogtreecommitdiff
path: root/tests/lang/eval-okay-arithmetic.nix
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2013-08-02 16:03:02 +0000
committerEelco Dolstra <eelco.dolstra@logicblox.com>2013-08-02 16:03:02 +0000
commit47701677e88230abf7d9106c55f46aa660643ce7 (patch)
treea63fb4fde15c85de24b3d04a3346cd72c6e009ca /tests/lang/eval-okay-arithmetic.nix
parent5d147e125cea69e9a3b12f0ef64c64f42985c65e (diff)
Add integer ‘-’, ‘*’ and ‘/’ operators
Diffstat (limited to 'tests/lang/eval-okay-arithmetic.nix')
-rw-r--r--tests/lang/eval-okay-arithmetic.nix6
1 files changed, 6 insertions, 0 deletions
diff --git a/tests/lang/eval-okay-arithmetic.nix b/tests/lang/eval-okay-arithmetic.nix
index 76bef919b..70179c5d1 100644
--- a/tests/lang/eval-okay-arithmetic.nix
+++ b/tests/lang/eval-okay-arithmetic.nix
@@ -22,5 +22,11 @@ let {
[ (sum (range 1 50))
(123 + 456)
(0 + -10 + -(-11) + -x)
+ (10 - 7 - -2)
+ (10 - (6 - -1))
+ (10 - 1 + 2)
+ (3 * 4 * 5)
+ (56088 / 123 / 2)
+ (3 + 4 * const 5 0 - 6 / id 2)
];
}