aboutsummaryrefslogtreecommitdiff
path: root/tests/lang/eval-okay-attrs5.nix
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2011-07-13 12:19:57 +0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2011-07-13 12:19:57 +0000
commit0a623a10c7e89a80b6dc74445a0ae6240f65723e (patch)
tree1c7a415095c4851c69d9b4c5dd1fea46a961a37c /tests/lang/eval-okay-attrs5.nix
parent2b9e29b1c8b6b8e4884a46a3ba71ee795f1f97cd (diff)
* Allow a default value in attribute selection by writing
x.y.z or default (as originally proposed in https://mail.cs.uu.nl/pipermail/nix-dev/2009-September/002989.html). For instance, an expression like stdenv.lib.attrByPath ["features" "ckSched"] false args can now be written as args.features.ckSched or false
Diffstat (limited to 'tests/lang/eval-okay-attrs5.nix')
-rw-r--r--tests/lang/eval-okay-attrs5.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/tests/lang/eval-okay-attrs5.nix b/tests/lang/eval-okay-attrs5.nix
new file mode 100644
index 000000000..e77ee7a1c
--- /dev/null
+++ b/tests/lang/eval-okay-attrs5.nix
@@ -0,0 +1,21 @@
+with import ./lib.nix;
+
+let
+
+ as = { x.y.z = 123; a.b.c = 456; };
+
+ bs = { foo.bar = "foo"; };
+
+ or = x: y: x || y;
+
+in
+ [ as.x.y.z
+ as.foo or "foo"
+ as.x.y.bla or as.a.b.c
+ as.a.b.c or as.x.y.z
+ as.x.y.bla or bs.foo.bar or "xyzzy"
+ as.x.y.bla or bs.bar.foo or "xyzzy"
+ 123.bla or null.foo or "xyzzy"
+ # Backwards compatibility test.
+ (fold or [] [true false false])
+ ]