aboutsummaryrefslogtreecommitdiff
path: root/tests/lang/eval-okay-fromjson.nix
diff options
context:
space:
mode:
authorMathnerd314 <mathnerd314.gph+hs@gmail.com>2015-09-04 14:23:08 -0600
committerJohn Ericson <John.Ericson@Obsidian.Systems>2023-07-11 21:43:09 -0400
commitc70484454f52a3bba994ac0c155b4a6f35a5013c (patch)
tree024cda6d4e26ffc6396bed4da9e172eeba2001d3 /tests/lang/eval-okay-fromjson.nix
parentc2c8187118c4bf2961aa175ff8667e1402a767c7 (diff)
Expanded test suite
* Lang now verifies errors and parse output * Some new miscellaneous tests * Easy way to update the tests * Document workflow in manual * Use `!` not `~` as separater char for sed It is confusing to use `~` when we are talking about paths and home directories! * Test test suite itself (`test/lang-test/infra.sh`) Additionally, run shellcheck on `tests/lang.sh` to help ensure it is correct, now that is is more complex. Co-authored-by: Robert Hensing <roberth@users.noreply.github.com> Co-authored-by: Valentin Gagarin <valentin.gagarin@tweag.io>
Diffstat (limited to 'tests/lang/eval-okay-fromjson.nix')
-rw-r--r--tests/lang/eval-okay-fromjson.nix14
1 files changed, 10 insertions, 4 deletions
diff --git a/tests/lang/eval-okay-fromjson.nix b/tests/lang/eval-okay-fromjson.nix
index e1c0f86cc..4c526b9ae 100644
--- a/tests/lang/eval-okay-fromjson.nix
+++ b/tests/lang/eval-okay-fromjson.nix
@@ -11,9 +11,12 @@ builtins.fromJSON
"Width": 200,
"Height": 250
},
+ "Animated" : false,
+ "IDs": [116, 943, 234, 38793, true ,false,null, -100],
+ "Escapes": "\"\\\/\t\n\r\t",
"Subtitle" : false,
- "Latitude": 46.2051,
- "Longitude": 6.0723
+ "Latitude": 37.7668,
+ "Longitude": -122.3959
}
}
''
@@ -28,8 +31,11 @@ builtins.fromJSON
Width = 200;
Height = 250;
};
+ Animated = false;
+ IDs = [ 116 943 234 38793 true false null (0-100) ];
+ Escapes = "\"\\\/\t\n\r\t"; # supported in JSON but not Nix: \b\f
Subtitle = false;
- Latitude = 46.2051;
- Longitude = 6.0723;
+ Latitude = 37.7668;
+ Longitude = -122.3959;
};
}