aboutsummaryrefslogtreecommitdiff
path: root/tests/lang/eval-okay-listtoattrs.nix
diff options
context:
space:
mode:
authorJohn Ericson <John.Ericson@Obsidian.Systems>2023-10-05 12:12:18 -0400
committerJohn Ericson <John.Ericson@Obsidian.Systems>2023-12-01 12:06:43 -0500
commit30dcc19d1f30fc203be460134c4578509cce704f (patch)
tree6cc32609b9984a2c4d5ecc0cac5cf30609e208b9 /tests/lang/eval-okay-listtoattrs.nix
parent72425212657d795dc215b334b7c8c8cd36d06b72 (diff)
Put functional tests in `tests/functional`
I think it is bad for these reasons when `tests/` contains a mix of functional and integration tests - Concepts is harder to understand, the documentation makes a good unit vs functional vs integration distinction, but when the integration tests are just two subdirs within `tests/` this is not clear. - Source filtering in the `flake.nix` is more complex. We need to filter out some of the dirs from `tests/`, rather than simply pick the dirs we want and take all of them. This is a good sign the structure of what we are trying to do is not matching the structure of the files. With this change we have a clean: ```shell-session $ git show 'HEAD:tests' tree HEAD:tests functional/ installer/ nixos/ ``` (cherry picked from commit 68c81c737571794f7246db53fb4774e94fcf4b7e)
Diffstat (limited to 'tests/lang/eval-okay-listtoattrs.nix')
-rw-r--r--tests/lang/eval-okay-listtoattrs.nix11
1 files changed, 0 insertions, 11 deletions
diff --git a/tests/lang/eval-okay-listtoattrs.nix b/tests/lang/eval-okay-listtoattrs.nix
deleted file mode 100644
index 4186e029b..000000000
--- a/tests/lang/eval-okay-listtoattrs.nix
+++ /dev/null
@@ -1,11 +0,0 @@
-# this test shows how to use listToAttrs and that evaluation is still lazy (throw isn't called)
-with import ./lib.nix;
-
-let
- asi = name: value : { inherit name value; };
- list = [ ( asi "a" "A" ) ( asi "b" "B" ) ];
- a = builtins.listToAttrs list;
- b = builtins.listToAttrs ( list ++ list );
- r = builtins.listToAttrs [ (asi "result" [ a b ]) ( asi "throw" (throw "this should not be thrown")) ];
- x = builtins.listToAttrs [ (asi "foo" "bar") (asi "foo" "bla") ];
-in concat (map (x: x.a) r.result) + x.foo