aboutsummaryrefslogtreecommitdiff
path: root/tests/nixos/remote-builds-ssh-ng.nix
diff options
context:
space:
mode:
authoreldritch horrors <pennae@lix.systems>2024-03-07 02:58:26 +0100
committereldritch horrors <pennae@lix.systems>2024-03-06 21:32:47 -0700
commit097acae35bd99cebd6cdb22cd6e498f3a50951f1 (patch)
tree502d6e2794d064f116d4c05e3a4828732fd73fd0 /tests/nixos/remote-builds-ssh-ng.nix
parent65f1b15c953805816133db3d3f92ff4c35c57741 (diff)
tests/nixos: Test remote build against older versions
(cherry picked from commit e502d1cf945fb3cdd0ca1e1c16ec330ccab51c7b) Change-Id: If6a1758b6457c5dae9305829c4d71d1905cfca22
Diffstat (limited to 'tests/nixos/remote-builds-ssh-ng.nix')
-rw-r--r--tests/nixos/remote-builds-ssh-ng.nix21
1 files changed, 18 insertions, 3 deletions
diff --git a/tests/nixos/remote-builds-ssh-ng.nix b/tests/nixos/remote-builds-ssh-ng.nix
index b59dde9bf..c75ad7253 100644
--- a/tests/nixos/remote-builds-ssh-ng.nix
+++ b/tests/nixos/remote-builds-ssh-ng.nix
@@ -1,4 +1,4 @@
-{ config, lib, hostPkgs, ... }:
+test@{ config, lib, hostPkgs, ... }:
let
pkgs = config.nodes.client.nixpkgs.pkgs;
@@ -28,12 +28,27 @@ let
in
{
- name = "remote-builds-ssh-ng";
+ name = lib.mkDefault "remote-builds-ssh-ng";
+
+ # TODO expand module shorthand syntax instead of use imports
+ imports = [{
+ options = {
+ builders.config = lib.mkOption {
+ type = lib.types.deferredModule;
+ description = ''
+ Configuration to add to the builder nodes.
+ '';
+ default = { };
+ };
+ };
+ }];
nodes =
{ builder =
{ config, pkgs, ... }:
- { services.openssh.enable = true;
+ {
+ imports = [ test.config.builders.config ];
+ services.openssh.enable = true;
virtualisation.writableStore = true;
nix.settings.sandbox = true;
nix.settings.substituters = lib.mkForce [ ];