aboutsummaryrefslogtreecommitdiff
path: root/tests/nixos/sourcehut-flakes.nix
diff options
context:
space:
mode:
authoreldritch horrors <pennae@lix.systems>2024-04-18 21:03:03 +0200
committereldritch horrors <pennae@lix.systems>2024-04-18 20:09:19 +0000
commita326344253ee55d50476ff696b83ffb15366852d (patch)
tree3d67eb58d8629e7e44bf5f60134f6291e63e28a0 /tests/nixos/sourcehut-flakes.nix
parentf9d08cc44c615606186d65fe2e500d10488bf8e4 (diff)
tests: unhaunt the flakes nixos tests
these should really wait for networks to come up, otherwise they can fail. fixes #235 Change-Id: I08989e8bdb0de280df74660ac43983de5c34fa9d
Diffstat (limited to 'tests/nixos/sourcehut-flakes.nix')
-rw-r--r--tests/nixos/sourcehut-flakes.nix4
1 files changed, 4 insertions, 0 deletions
diff --git a/tests/nixos/sourcehut-flakes.nix b/tests/nixos/sourcehut-flakes.nix
index 04f3590e1..714b518d1 100644
--- a/tests/nixos/sourcehut-flakes.nix
+++ b/tests/nixos/sourcehut-flakes.nix
@@ -121,6 +121,10 @@ in
start_all()
+ client.succeed("systemctl start network-online.target")
+ sourcehut.succeed("systemctl start network-online.target")
+ client.wait_for_unit("network-online.target")
+ sourcehut.wait_for_unit("network-online.target")
sourcehut.wait_for_unit("httpd.service")
client.succeed("curl -v https://git.sr.ht/ >&2")