aboutsummaryrefslogtreecommitdiff
path: root/tests/remote-builds.nix
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2014-07-14 12:19:27 +0200
committerEelco Dolstra <eelco.dolstra@logicblox.com>2014-07-14 12:19:27 +0200
commitfa13d3f4f3d8fb6dc3e3fc87ac5a2e26d8b32d84 (patch)
tree6f18ceb94403c242d3c8174663d135c5ba8a4251 /tests/remote-builds.nix
parentb2e0293f022123b11759dfd498d4eff72233d3f7 (diff)
build-remote.pl: Fix building multiple output derivations
We were importing paths without sorting them topologically, leading to "path is not valid" errors. See e.g. http://hydra.nixos.org/build/12451761
Diffstat (limited to 'tests/remote-builds.nix')
-rw-r--r--tests/remote-builds.nix5
1 files changed, 3 insertions, 2 deletions
diff --git a/tests/remote-builds.nix b/tests/remote-builds.nix
index 571cdfbdd..eb80a7d7e 100644
--- a/tests/remote-builds.nix
+++ b/tests/remote-builds.nix
@@ -25,7 +25,8 @@ let
system = "i686-linux";
PATH = "''${utils}/bin";
builder = "''${utils}/bin/sh";
- args = [ "-c" "echo Hello; mkdir $out; cat /proc/sys/kernel/hostname > $out/host; sleep 3" ];
+ args = [ "-c" "echo Hello; mkdir $out $foo; cat /proc/sys/kernel/hostname > $out/host; ln -s $out $foo/bar; sleep 5" ];
+ outputs = [ "out" "foo" ];
}
'';
@@ -86,7 +87,7 @@ in
# And a parallel build.
my ($out1, $out2) = split /\s/,
- $client->succeed("nix-store -r \$(nix-instantiate ${expr nodes.client.config 2} ${expr nodes.client.config 3})");
+ $client->succeed('nix-store -r $(nix-instantiate ${expr nodes.client.config 2})\!out $(nix-instantiate ${expr nodes.client.config 3})\!out');
$slave1->succeed("test -e $out1 -o -e $out2");
$slave2->succeed("test -e $out1 -o -e $out2");