aboutsummaryrefslogtreecommitdiff
path: root/tests/shell-hello.nix
diff options
context:
space:
mode:
authorMatthew Kenigsberg <matthewkenigsberg@gmail.com>2020-04-29 15:37:21 -0600
committerEelco Dolstra <edolstra@gmail.com>2020-05-01 12:17:53 +0200
commit2852a486f864c385696fb7ee28836b183976ca63 (patch)
treec1a763c8fe489afe0021383814de2b7f797f1db0 /tests/shell-hello.nix
parentd6b4047c2fd8c197bf7a9f0f9a2f1cfb214e2e89 (diff)
rename run to shell in tests
(cherry picked from commit f459ca547fda4b0ca477d895413e86b69a580ab0)
Diffstat (limited to 'tests/shell-hello.nix')
-rw-r--r--tests/shell-hello.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/tests/shell-hello.nix b/tests/shell-hello.nix
new file mode 100644
index 000000000..77dcbd2a9
--- /dev/null
+++ b/tests/shell-hello.nix
@@ -0,0 +1,17 @@
+with import ./config.nix;
+
+{
+ hello = mkDerivation {
+ name = "hello";
+ buildCommand =
+ ''
+ mkdir -p $out/bin
+ cat > $out/bin/hello <<EOF
+ #! ${shell}
+ who=\$1
+ echo "Hello \''${who:-World} from $out/bin/hello"
+ EOF
+ chmod +x $out/bin/hello
+ '';
+ };
+}