aboutsummaryrefslogtreecommitdiff
path: root/tests/shell.nix
diff options
context:
space:
mode:
authorEelco Dolstra <edolstra@gmail.com>2017-02-24 17:25:22 +0100
committerEelco Dolstra <edolstra@gmail.com>2017-02-24 17:29:02 +0100
commit89ffe1eff946639aa2752177fcc5159b6926af70 (patch)
treeb884d3b966d402a66fba46ff7ca771df422d0c1a /tests/shell.nix
parentd3e1aad421a88a7a075cac25142c49224b3ecca2 (diff)
Fix nix-shell tests
The nix-shell fix in 668fef2e4f1c7758e2a55e355b4826014d5b7ba9 revealed that we had some --pure tests that incorrectly depended on PATH from config.nix's mkDerivation being overwritten by the caller's PATH. http://hydra.nixos.org/build/49242478
Diffstat (limited to 'tests/shell.nix')
-rw-r--r--tests/shell.nix1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/shell.nix b/tests/shell.nix
index ed4d6fbaa..1a092913b 100644
--- a/tests/shell.nix
+++ b/tests/shell.nix
@@ -34,6 +34,7 @@ rec {
mkdir -p $out/bin
echo 'echo foo' > $out/bin/foo
chmod a+rx $out/bin/foo
+ ln -s ${shell} $out/bin/bash
'';
bar = runCommand "bar" {} ''