aboutsummaryrefslogtreecommitdiff
path: root/tests/structured-attrs.nix
diff options
context:
space:
mode:
authorJohn Ericson <John.Ericson@Obsidian.Systems>2023-10-05 12:12:18 -0400
committerJohn Ericson <John.Ericson@Obsidian.Systems>2023-12-01 12:06:43 -0500
commit30dcc19d1f30fc203be460134c4578509cce704f (patch)
tree6cc32609b9984a2c4d5ecc0cac5cf30609e208b9 /tests/structured-attrs.nix
parent72425212657d795dc215b334b7c8c8cd36d06b72 (diff)
Put functional tests in `tests/functional`
I think it is bad for these reasons when `tests/` contains a mix of functional and integration tests - Concepts is harder to understand, the documentation makes a good unit vs functional vs integration distinction, but when the integration tests are just two subdirs within `tests/` this is not clear. - Source filtering in the `flake.nix` is more complex. We need to filter out some of the dirs from `tests/`, rather than simply pick the dirs we want and take all of them. This is a good sign the structure of what we are trying to do is not matching the structure of the files. With this change we have a clean: ```shell-session $ git show 'HEAD:tests' tree HEAD:tests functional/ installer/ nixos/ ``` (cherry picked from commit 68c81c737571794f7246db53fb4774e94fcf4b7e)
Diffstat (limited to 'tests/structured-attrs.nix')
-rw-r--r--tests/structured-attrs.nix70
1 files changed, 0 insertions, 70 deletions
diff --git a/tests/structured-attrs.nix b/tests/structured-attrs.nix
deleted file mode 100644
index e93139a44..000000000
--- a/tests/structured-attrs.nix
+++ /dev/null
@@ -1,70 +0,0 @@
-with import ./config.nix;
-
-let
-
- dep = mkDerivation {
- name = "dep";
- buildCommand = ''
- mkdir $out; echo bla > $out/bla
- '';
- };
-
-in
-
-mkDerivation {
- name = "structured";
-
- __structuredAttrs = true;
-
- outputs = [ "out" "dev" ];
-
- buildCommand = ''
- set -x
-
- [[ $int = 123456789 ]]
- [[ -z $float ]]
- [[ -n $boolTrue ]]
- [[ -z $boolFalse ]]
- [[ -n ''${hardening[format]} ]]
- [[ -z ''${hardening[fortify]} ]]
- [[ ''${#buildInputs[@]} = 7 ]]
- [[ ''${buildInputs[2]} = c ]]
- [[ -v nothing ]]
- [[ -z $nothing ]]
-
- mkdir ''${outputs[out]} ''${outputs[dev]}
- echo bar > $dest
- echo foo > $dest2
-
- json=$(cat $NIX_ATTRS_JSON_FILE)
- [[ $json =~ '"narHash":"sha256:1r7yc43zqnzl5b0als5vnyp649gk17i37s7mj00xr8kc47rjcybk"' ]]
- [[ $json =~ '"narSize":288' ]]
- [[ $json =~ '"closureSize":288' ]]
- [[ $json =~ '"references":[]' ]]
- '';
-
- buildInputs = [ "a" "b" "c" 123 "'" "\"" null ];
-
- hardening.format = true;
- hardening.fortify = false;
-
- outer.inner = [ 1 2 3 ];
-
- int = 123456789;
-
- float = 123.456;
-
- boolTrue = true;
- boolFalse = false;
-
- nothing = null;
-
- dest = "${placeholder "out"}/foo";
- dest2 = "${placeholder "dev"}/foo";
-
- "foo bar" = "BAD";
- "1foobar" = "BAD";
- "foo$" = "BAD";
-
- exportReferencesGraph.refs = [ dep ];
-}